The Bard’s Tale IV Now Requires Windows 10

The Bard's Tale IV Director's Cut Requires Windows 10

Some players have reported that The Bard’s Tale IV stopped running on their machines after installing the latest update. According to a developer that posted in a related Steam discussion thread, The Bard’s Tale IV now requires Windows 10 since Microsoft stopped the support of Windows 7:

“Copy/pasta of my recent response in the bug reporting thread: Microsoft has ended support for Windows 7, and with the latest update to the game we followed suit and have raised the game’s minimum system requirements to Windows 10. If you’re on an older version of Windows, of course our recommendation is to upgrade/update to the latest version. If that’s not possible for you, please contact our support directly and we’ll see if there’s some way we can assist. https://inxile.zendesk.com/hc/en-us/requests/new

The players are unhappy with the system requirements of the game being raised post-release. Others have pointed out the fact that Microsoft will continue to support Windows 8.1 for another three or so years, but the developers left it without comment. Stay tuned to see how the situation develops further!

Written by
While growing up in the wilds of Russia, Catherine learned to talk, write and game at almost the same time. You can follow her attempts at latter two at MMORPG.com and GameSpace.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Lost Password

Please enter your username or email address. You will receive a link to create a new password via email.